I2P-Bote 0.3 temporarily disabled IMAP support due to a bug. In I2P 0.9.24 the bug was fixed, by removing the old commons-logging.jar library, and so in 0.4.3 IMAP has been re-enabled. However, older versions of I2P-Bote required this library. Removing it will therefore have two effects:

  1. I2P-Bote 0.4.3+ will require at least I2P 0.9.24 to run (it would crash on earlier versions if IMAP was enabled).
  2. I2P-Bote older than 0.3 (any version signed by HungryHobo) will crash on startup after upgrading I2P to 0.9.24+, if IMAP is enabled.

If you are already running I2P-Bote 0.3+ then you don't need to do anything - the router will upgrade your plugin after it is restarted for its upgrade. If you are running version 0.2.10 or below, follow the instructions on the installation page to upgrade.

If for some reason you do not wish to upgrade from HungryHobo's builds, then you can instead fix the crash by disabling IMAP. But if you were only still on those builds for IMAP support, 0.4.3 now has IMAP, so you should upgrade :)